Сервер в кармане, или просто о сложном!

главная - Статьи - Mikrotik



Mikrotik перенаправление на прозрачный прокси

Дата обновления: 10.08.2021

Теги: Mikrotik

Если нужно перенаправить трафик (например, http и htttps) на прозрачный прокси, то с помощью Mikrotik это можно сделать так:

Освоить MikroTik Вы можете с помощью онлайн-куса «Настройка оборудования MikroTik». Курс основан на официальной программе MTCNA. Автор курса – официальный тренер MikroTik. Подходит и тем, кто уже давно работает с микротиками, и тем, кто еще их не держал в руках. В курс входит 162 видеоурока, 45 лабораторных работ, вопросы для самопроверки и конспект.

Создаем список адресов, трафик с которых будем перенаправлять на прокси:

/ip firewall address-list add address=192.168.100.10-192.168.100.60 list=proxy_clients

Помечаем нужный вид трафика (в данном случае это tcp/80, tcp/443) меткой "to_proxy":

/ip firewall mangle add action=mark-routing chain=prerouting dst-port=80,443 new-routing-mark=to_proxy protocol=tcp src-address-list=proxy_clients

Для помеченного трафика создаем маршрут:

/ip route add distance=1 gateway=192.168.100.254 routing-mark=to_proxy

Все. Теперь трафик нужных клиентов будет не "натиться", а будет отправлен прямиком на прокси-сервер. При этом не нужно перенастраивать рабочие станции, маршрутизация в сети не будет нуждаться в изменениях. Это может пригодиться, к примеру, если тестируется прокси-сервер и не хочется перестраивать работу сети сразу.



Авторизуйтесь для добавления комментариев!


    забыли пароль?    новый пользователь?